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Create a hyperlink to a web page (URL)

You can use several different methods to create hy-
perlinks to URLs. When you specify a URL, you can 
use any valid Internet resource protocol: http://, file://, 
ftp://, or mailto://.

You can also use the Buttons feature to link to web 
pages. (See Buttons.)

You may want to create a character style for hyper-
links. Hyperlinks are often formatted in underlined 
blue text.

   1.	 Select the text, frame, or graphic you want to 
be the hyperlink’s source. For example, you 
can select the text, “See the Adobe website.”

   2.	 In the Hyperlinks panel, use any of the fol-
lowing methods to create a hyperlink to a 
URL:

•	 In the URL text box, type or paste the URL 
name (such as http://www.adobe.com), and then 
choose New Hyperlink from the Hyperlinks 
panel. Choose URL from the Link To menu, 
specify appearance options, and click OK.

•	 If a URL is selected in your document, choose 
New Hyperlink From URL in the Hyperlinks 
panel menu. Double-click the hyperlink in the 
Hyperlinks panel, and then choose URL from the 
Link To menu, specify appearance options, and 
click OK.

•	  Select a previously added URL from the URL 
menu. The hyperlink appearance is the same as 
that used in the previous URL.

•	   Choose New Hyperlink in the Hyperlinks panel 
menu. Choose URL from the Link To menu, 
specify appearance options, and click OK.

Note: If a URL hyperlink isn’t working in the ex-
ported PDF, there may be a problem with the hyper-
link being a “Shared Destination.” Double-click the 
hyperlink in the Hyperlinks panel, choose URL from 
the Link To menu, deselect Shared Hyperlink Destina-
tion, and click OK.

Create a hyperlink to a file

When you create a hyperlink to a file, clicking the 
hyperlink in the exported PDF or SWF file opens the 
file in its native application, such as Microsoft Word 
for .doc files.

Make sure the file you specify is available to anyone 
opening the PDF or SWF file you export. For example, 
if you’re sending the exported PDF to a coworker, 
specify a file located on a shared server rather than 
your hard drive.

   1. 	 Select the text, frame, or graphic you want to 
be the source of the hyperlink.

   2. 	 Choose New Hyperlink in the Hyperlinks 
panel menu, or click the Create New Hyper-
link button  at the bottom of the Hyperlinks 
panel.

   3. 	 In the New Hyperlink dialog box, choose File 
from the Link To menu.

   4. 	 For Path, type the pathname or click the 
folder button to locate and double-click the 
filename.

   5. 	 Select Shared Hyperlink Destination if you 
want the email message to be stored in the 
Hyperlinks panel for easy reuse.

   6. 	 Specify the appearance of the hyperlink 
source, and then click OK.

Create a hyperlink to an email message

   1. 	 Select the text, frame, or graphic you want to 
be the source of the hyperlink.

   2. 	 Choose New Hyperlink in the Hyperlinks 
panel menu, or click the Create New Hyper-
link button  at the bottom of the Hyperlinks 
panel.

   3. 	 In the New Hyperlink dialog box, choose 
Email from the Link To menu.

   4. 	 For Address, type the email address, such as 
username@company.com.
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   5. 	 For Subject Line, type the text that appears in 
the subject line of the email message.

   6. 	 Select Shared Hyperlink Destination if you 
want the email message to be stored in the 
Hyperlinks panel for easy reuse.

   7. 	 Specify the appearance of the hyperlink 
source, and then click OK.

Create a hyperlink to a page

You can create a hyperlink to a page without first 
creating a destination. However, by creating a page 
destination, you can specify a page number and view 
setting.

   1. 	 Select the text, frame, or graphic you want to 
be the source of the hyperlink.

   2. 	 Choose New Hyperlink in the Hyperlinks 
panel menu, or click the Create New Hyper-
link button  at the bottom of the Hyperlinks 
panel.

   3. 	 In the New Hyperlink dialog box, choose 
Page from the Link To menu.

   4. 	 For Document, select the document contain-
ing the destination that you want to jump to. 
All open documents that have been saved are 
listed in the pop‑up menu. If the document 
you’re looking for isn’t open, select Browse 
in the pop‑up menu, locate the file, and then 
click Open.

   5. 	 For Page, specify the page number you want 
to jump to.

   6. 	 For Zoom Setting, do one of the following to 
select the view state of the page being jumped 
to:

•	 Select Fixed to display the magnification level 
and page position that were in effect when you 
created the link.

•	  Select Fit View to display the visible portion of 
the current page as the destination.

•	 Select Fit In Window to display the current page 
in the destination window.

•	  Select Fit Width or Fit Height to display the 
width or height of the current page in the desti-
nation window.

•	 Select Fit Visible to display the page so that its 
text and graphics fit the width of the window, 
which usually means that the margins are not 
displayed.

•	 Select Inherit Zoom to display the destination 

window at the magnification level the reader uses 
when the hyperlink is clicked.

   7. 	 Specify appearance options, and then click 
OK.

Create a hyperlink destination

Creating a hyperlink destination is necessary only if 
you’re creating a hyperlink or cross-reference to a text 
anchor. A text anchor can point to a selection of text or 
to the insertion point location. Then you create the hy-
perlink or cross-reference that points to the hyperlink 
destination. You can also create hyperlink destinations 
for pages and URLs, but a destination isn’t necessary 
for those links.

Hyperlink destinations you create do not appear in 
the Hyperlinks panel; they appear in the dialog box 
that appears when you’re creating or editing hyper-
links.

   1. 	 If you’re creating a text anchor, use the Type 
tool to place the insertion point, or select the 
range of text that you want to be the anchor.
You cannot set up an anchor destination for 
text on a master page.

   2. 	 Choose New Hyperlink Destination in the 
Hyperlinks panel menu.

   3. 	 Do any of the following, and then click OK:
•	 Choose Text Anchor in the Type menu. Specify a 

name for the text anchor.
•	 Choose Page in the Type menu. Specify the page 

number you want to jump to and the Zoom Set-
ting. Type a name for the page, or select Name 
With Page Number to name the destination au-
tomatically based on the page number and zoom 
setting you specify.

•	  Choose URL in the Type menu. Type or paste 
a URL, such as http://www.adobe.com. You can 
use any valid Internet resource protocol: http://, 
file://, ftp://, or mailto://.

Create a hyperlink to a text anchor

1.	 Select the text, frame, or graphic you want to be 
the source of the hyperlink.

2.	 Choose New Hyperlink in the Hyperlinks panel 
menu, or click the Create New Hyperlink button 
at the bottom of the Hyperlinks panel.

3.	 Choose Text Anchor from the Link To menu.
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4.	 For Document, select the document contain-
ing the destination that you want to jump to. 
All open documents that have been saved are 
listed in the pop‑up menu. If the document 
you’re looking for isn’t open, select Browse in 
the pop‑up menu, locate the file, and then click 
Open.

5.	 From the Text Anchor menu, choose the text 
anchor destination you created.

6.	 Specify hyperlink appearance options, and then 
click OK.

Create a hyperlink to any shared destination

While creating a hyperlink, if you choose Shared 
Destination from the Link To menu, you can specify 
any named destination. A destination is named when 
you add a URL using the URL text box or when you 
select Shared Hyperlink Destination while creating a 
hyperlink to a URL, file, or email address.

1.	 Select the text, frame, or graphic you want to be 
the source of the hyperlink.

2.	 Choose New Hyperlink in the Hyperlinks panel 
menu, or click the Create New Hyperlink button 
at the bottom of the Hyperlinks panel.

3.	 In the New Hyperlink dialog box, choose Shared 
Destination from the Link To menu.

4.	 For Document, select the document contain-
ing the destination that you want to jump to. 
All open documents that have been saved are 
listed in the pop‑up menu. If the document 
you’re looking for isn’t open, select Browse in 
the pop‑up menu, locate the file, and then click 
Open.

5.	 Choose a destination from the Name menu.
6.	 Specify hyperlink appearance options, and then 

click OK.

Hyperlink appearance options

The options determine the appearance of the hyper-
link or cross-reference source in the exported PDF or 
SWF file. These appearance options are also displayed 
in the InDesign document if you choose View > Show 
Hyperlinks.

Character Style
    Choose a character style to apply to the hyperlink 

source. The Character Style option is available only 

if the hyperlink source is selected text, not a selected 
frame or graphic.

  If you’re inserting a cross-reference, you can ap-
ply a character style when you edit a cross-reference 
format. You can also apply character styles to build-
ing blocks within a format. See Using cross-reference 
formats.

Type
    Select Visible Rectangle or Invisible Rectangle.

Highlight
    Select Invert, Outline, Inset, or None. These op-

tions determine the appearance of the hyperlink when 
it’s being clicked in the PDF or SWF file.

Color
    Select a color for the visible hyperlink rectangle.

Width
    Select Thin, Medium, or Thick to determine the 

thickness of the hyperlink rectangle.

Style
    Select Solid or Dashed to determine the appear-

ance of the hyperlink rectangle. 

Create bookmarks for PDF

A bookmark is a type of link with representative text 
that makes it easier to navigate documents exported 
as Adobe PDF. Bookmarks you create in the InDesign 
document appear in the Bookmarks tab on the left side 
of the Acrobat or Adobe Reader window. Each book-
mark jumps to a text anchor or a page.

Entries in a generated table of contents are automati-
cally added to the Bookmarks panel. In addition, you 
can further customize your document with bookmarks 
to direct a reader’s attention or make navigation even 
easier. Bookmarks can be nested under other book-
marks.

You may want bookmarks to appear in the Book-
marks tab of the PDF document, but you don’t want 
the table of contents to appear in the PDF. In this case, 
generate a table of contents on the last page of the 
document. When you export to PDF, don’t include the 
last page. Or, if you include the last page of the ex-
ported PDF, delete it in Acrobat.

1. 	 Choose Window > Interactive > Bookmarks 
to display the Bookmarks panel.
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   2. 	 Click the bookmark under which you want to 
place the new bookmark. If you don’t select 
a bookmark, the new bookmark is automati-
cally added to the end of the list.

   3. 	 Do one of the following to indicate where you 
want the bookmark to jump:

•	 Click an insertion point in text.
•	 Select text. (By default, the text you select be-

comes the bookmark label.)
•	 Double-click a page in the Pages panel to view it 

in the document window.
   4. 	 Do one of the following to create the book-

mark:
•	 Click the Create New Bookmark icon on the 

Bookmarks panel.
•	 Choose New Bookmark from the panel menu.

Manage bookmarks

Use the Bookmarks panel to rename, delete, and ar-
range bookmarks.

Rename a bookmark
Click the bookmark in the Bookmarks panel, and 

choose Rename Bookmark from the panel menu.

Delete a bookmark
 Click a bookmark in the Bookmarks panel, and 

choose Delete Bookmark from the panel menu.

Arrange, group, and sort bookmarks
You can nest a list of bookmarks to show a relation-

ship between topics. Nesting creates a parent/child 
relationship. You can expand and collapse this hier-
archical list as desired. Changing the order or nesting 
order of bookmarks does not affect the appearance of 
your actual document.

 Do one of the following:
•	 To expand and collapse the bookmark hierarchy, 

click the triangle next to the bookmark icon to 
show or hide any children it contains.

•	 To nest a bookmark under another bookmark, 
select the bookmark or range of bookmarks you 
want to nest, and then drag the icon or icons onto 
the parent bookmark. Release the bookmark.

•	 The bookmark or bookmarks you dragged are 
nested under the parent bookmark; however, the 
actual page remains in its original location in the 
document.

•	 Bookmarks panel showing bookmarks being 

nested under a parent bookmark
•	 To move a bookmark out of a nested position, 

select the bookmark or range of bookmarks you 
want to move. Drag the icon or icons below and 
to the left of the parent bookmark. A black bar 
appears indicating where the bookmark will be 
moved. Release the bookmark.

•	 To change the order of bookmarks, select a 
bookmark and move it to a new location. A black 
bar appears indicating where the bookmark will 
be placed.

•	 To sort bookmarks, choose Sort Bookmarks from 
the Bookmarks panel menu. Bookmarks appear 
in the same order as the pages they jump to.

Adding Movies or sound

You can add movies and sound clips to a document, 
or you can link to streaming video files on the Internet. 
Although media clips cannot be played directly in the 
InDesign layout, they can be played when you export 
the document to Adobe PDF or when you export the 
document to XML and repurpose the tags.

A poster is the image that represents a media clip. 
Each movie or sound can appear with or without a 
poster. If the poster in InDesign is larger than the 
movie, the poster is clipped to the size of the movie in 
the exported PDF document.

QuickTime 6.0 or later is required to work with 
movies in InDesign. You can add QuickTime, AVI, 
MPEG, and SWF movies. However, QuickTime no 
longer offers full support of SWF files. You can also 
add WAV, AIF, and AU sound clips. InDesign supports 
only 8‑ or 16‑bit WAV files that are not compressed.

Keep track of the media files you add to an InDesign 
document during the production cycle. If you move a 
linked media clip after adding it to the document, use 
the Links panel to relink it. If you send the InDesign 
document to another person, include any media files 
you add.

For other users to view media in a PDF document, 
they must have Acrobat 6.x or later to play MPEG and 
SWF movies, or Acrobat 5.0 or later to play Quick-
Time and AVI movies.
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Add a movie or a sound file

   1. 	 Do any of the following:
•	  Choose File > Place, and then double-click the 

movie or sound file. Click where you want the 
movie to appear. (If you drag to create the media 
frame, the movie boundary may appear cropped 
or skewed.)

•	 Drag the media file from Explorer (Windows) or 
Finder (Mac OS) into the document.

•	  To convert a frame into a media clip, select the 
frame and choose Object > Interactive > Movie 
Options or Sound Options. This creates an empty 
movie or sound frame. (After you add a movie 
using this method, you may want to choose Ob-
ject > Fitting > Fit Frame To Content so that the 
frame is the same size as the movie.)

      	 When you place a movie or sound file, a 
media object appears in a frame. This media 
object links to the media file. You can resize 
the media object to determine the size of the 
play area.

	 If the center point of the movie appears 
outside the page, the movie is not exported to 
PDF.

   
2. 	 To change movie, sound, or poster options, 

double-click the media object.
      	 To preview a media file, hold down Alt (Win-

dows) or Option (Mac OS) and double-click 
a movie or sound object using the Selection 
tool.

   3. 	 Export the document to Adobe PDF. Make 
sure that the Interactive Elements option is 
selected in the Export Adobe PDF dialog box.

 Select Interactive Elements so that media clips can be played in 
the PDF document.

Adding SWF files in InDesign

If you place a SWF file in an InDesign document, 
Mac OS users may not be able to play the file in the 
exported PDF. For best results, leave a blank space 
in the InDesign document for the SWF file, and then 
add the SWF file in Adobe Acrobat 9. When you add 
a SWF to a PDF in Acrobat 9 (PDF 1.7) you add the 
animation as the “Rich Media” animation type, which 
uses Acrobat’s built-in Flash Player to play SWF con-
tent.

Link to a movie on the Internet

You may want an object to link to a web URL that 
plays a streaming media file. After you export the doc-
ument to Adobe PDF or to a different format, clicking 
the object plays the movie, if an Internet connection is 
available.

   1. 	 If necessary, draw a rectangle to be used as 
the play area. You can add a poster to this 
frame later.

   2. 	 Select an object, and then choose Object > 
Interactive > Movie Options.

   3. 	 Click Specify A URL, and then type or paste 
the URL.

   4. 	 Click Verify URL And Movie Size to make 
sure that the URL is valid. (You must have an 
Internet connection.)

   5. 	 Specify any other options, and then click OK.

Movie options

You can edit movie options by double-clicking the 
movie play area using the Selection tool, or by select-
ing the movie object and choosing Object > Interactive 
> Movie Options.

Description
    Type a description that appears if the movie can-

not be played in Acrobat. This description also acts as 
alternative text for visually impaired users.

Choose A File
    To specify a different movie clip, click the Browse 

(Windows) or Choose (Mac OS) button next to Choose 
A File, and then double-click the new filename. 
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Embed Movie In PDF
    Embedding the media file increases the file size of 

the PDF document but frees you from having to copy 
the media file to make it available to others. This op-
tion is not available if Specify A URL is selected.

    You can override this setting by linking or embed-
ding all media files, or you can use the settings for 
each object. Embedded movies require Acrobat 6.0 
and later, or Adobe Reader 6.0 and later. 

Specify A URL
    To play a streaming video from a website, select 

Specify A URL, and then type or paste the URL.

Poster
    Specify the type of image that you want to appear 

in the play area. 

Mode
    Determine whether the movie is played once and 

then closes (if it’s played in a floating window), played 
once but stays open, or played in a continuous loop.

Play On Page Turn
    Play the movie when someone turns to the page of 

the PDF document on which the movie is located.

Show Controller During Play
    Display a controller that lets users pause, start, 

and stop the movie.

Floating Window
    Play the movie in a separate window. If you select 

this option, specify the size ratio and position on the 
screen. Increasing the size of the floating window may 
reduce image quality. The floating window scale is 
based on the size of the original movie, not the size of 
the scaled movie in the document layout.

Sound options

You can edit sound options by double-clicking the 
sound play area using the Selection tool, or by select-
ing the sound object and choosing Object > Interactive 
> Sound Options.

Description
    Type a description that appears if the sound can-

not be played in Acrobat. This description also acts as 
alternative text for visually impaired users.

File
    To specify a different sound clip, click the Browse 

(Windows) or Choose (Mac OS) button next to File, 
and then double-click the new filename. 

Poster
    Specify the type of image that you want to appear 

in the play area.

Play On Page Turn
    Play the sound clip when someone turns to the 

page of the PDF document on which the sound is 
located.

Do Not Print Poster
    Select this option if you do not want the poster to 

print in InDesign.

Embed Sound In PDF
    Embedding the media file increases the file size 

of the PDF document but prevents you from having to 
send or copy the media file along with the PDF docu-
ment.

    You can override this setting by linking or embed-
ding all media files, or you can use the settings for 
each object. Sounds must be embedded to be played in 
some earlier versions of Acrobat. 

Poster options

You cannot simply use a placed image as a poster. 
Instead, specify any of the following types of poster 
images in the Movie Options or Sound Options dialog 
box:

None
    Shows no poster for the movie or sound clip. This 

option is useful if you want the movie or sound clip to 
not be visible on the page. For example, you may want 
the media to be played only when you turn the page, 
or you may want a more complex design beneath the 
movie to show instead of the poster.

Standard
    Displays a generic movie or sound poster that 

isn’t based on the contents of the file.
    
To use a different standard poster, save an image as 

StandardMoviePoster.jpg or StandardSoundPoster.jpg, 
and replace the existing file of the same name. This 
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file is located in the Presets/Images folder in the ap-
plication folder.

Default Poster
    Displays the poster image packaged with the 

movie file. If the selected movie doesn’t have a frame 
designated as the poster, the first frame of the movie is 
used as the poster image.

Frame From Movie
    This option is dimmed unless you specify a frame 

using the Choose Move Frame As Poster option.

Choose Image As Poster
    Lets you select an image to use as the poster. 

Click Browse, and then double-click the image you 
want to use. You can select bitmap graphics, not vector 
graphics, for posters.

    To use an image as a poster, you can also use the 
Direct Selection tool to select the poster frame, and 
then use the Place command to place a graphic inside 
the frame.

Choose Movie Frame As Poster
    Lets you select any video frame to use as the 

poster image. Supported formats include AVI, MPEG, 
MOV, and SWF. Drag the slider or use the arrow 
keys to advance through the movie clip to the desired 
frame, and then click OK.


